No Profanity *** No Flaming *** No Advertising *** No Anti Trappers *** No Politics
No Non-Target Catches *** No Links to Anti-trapping Sites *** No Avoiding Profanity Filter


Home~Trap Talk~ADC Forum~Trap Shed~Wilderness Trapping~International Trappers~Fur Handling

Auction Forum~Trapper Tips~Links~Gallery~Basic Sets~Convention Calendar~Chat~ Trap Collecting Forum

Trapper's Humor~Strictly Trapping~Fur Buyers Directory~Mugshots~Fur Sale Directory~Wildcrafting~The Pen and Quill

Trapper's Tales~Words From The Past~Legends~Archives~Kids Forum~Lure Formulators Forum~ Fermenter's Forum


~~~ Dobbins' Products Catalog ~~~


Minnesota Trapline Products
Please support our sponsor for the Trappers Talk Page - Minnesota Trapline Products


Print Thread
Hop To
2003 Chevy Silverado, Mechanic ?? #6748584
01/28/20 08:53 PM
01/28/20 08:53 PM
Joined: Sep 2010
Posts: 116
upper michigan
N
Nothwoods Bandit Offline OP
trapper
Nothwoods Bandit  Offline OP
trapper
N

Joined: Sep 2010
Posts: 116
upper michigan
Was wondering if anyone has any info on why the speedometer, and odometer quit working on my 2003 Silverado, it's the 5.3 automatic. I thought initially it was just the speedometer, so I took out the instrument panel and replaced the stepper motor. After putting it all back together it still didn't work, and that is when I noticed the odometer wasn't working either. I did some research online, and found out sometimes it is the speed sensor on the back of the transmission, so I picked one up and changed that, but still no difference. I am trying to avoid an expensive bill from the auto shops, and was hoping maybe if anyone has experienced this issue if you have any further recommendations??

Any info would be greatly appreciated!

N.B.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748591
01/28/20 08:55 PM
01/28/20 08:55 PM
Joined: Jun 2018
Posts: 3,237
Beatrice, NE
L
loosegoose Offline
trapper
loosegoose  Offline
trapper
L

Joined: Jun 2018
Posts: 3,237
Beatrice, NE
Chevy's from that vintage sometimes had issues with the instrument clusters. Solution is to replace it.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748592
01/28/20 08:56 PM
01/28/20 08:56 PM
Joined: Nov 2013
Posts: 23
PA
W
wrestlecoach Offline
trapper
wrestlecoach  Offline
trapper
W

Joined: Nov 2013
Posts: 23
PA
Yep, replace cluster

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748596
01/28/20 08:58 PM
01/28/20 08:58 PM
Joined: May 2011
Posts: 4,903
Montana
B
beartooth trapr Offline
trapper
beartooth trapr  Offline
trapper
B

Joined: May 2011
Posts: 4,903
Montana
Check the wiring going into the sensor plug in , my 2006 had this problem. They put the plastic tubing over the wires but mine still broke at the plug in . I had to cut it apart to find the problem.


Let me sugar coat this
Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748603
01/28/20 09:01 PM
01/28/20 09:01 PM
Joined: Dec 2019
Posts: 34
Missouri
F
Fleshnugget Offline
trapper
Fleshnugget  Offline
trapper
F

Joined: Dec 2019
Posts: 34
Missouri
Hello. I had the same year Sierra and the same thing happened to it about 6 years ago. I replaced the whole dash cluster. Bought it from rock auto and had to sign a declaration for the mileage and send the old one in for the core. Donít really remember what it cost me. I want to say $200.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748608
01/28/20 09:04 PM
01/28/20 09:04 PM
Joined: Jul 2011
Posts: 371
Custer SD
A
arcticotter Offline
trapper
arcticotter  Offline
trapper
A

Joined: Jul 2011
Posts: 371
Custer SD
Got an 03 Tahoe that did the same thing. There are a couple places in Minnesota that I found that put new motors in the cluster. Had mine done for about $125. Found them on EBay and sent it to them.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: wrestlecoach] #6748609
01/28/20 09:04 PM
01/28/20 09:04 PM
Joined: Sep 2010
Posts: 116
upper michigan
N
Nothwoods Bandit Offline OP
trapper
Nothwoods Bandit  Offline OP
trapper
N

Joined: Sep 2010
Posts: 116
upper michigan
I don't think it's in the cluster, I had some issues with the speedo a couple years ago and replaced the stepper motor and it worked fine. At that time the needle had been jumping all over the place and sometimes got stuck, but this time it just stays at the zero mark and doesn't move at all?? All the other gauges work fine, and I did replace the stepper again on the speedo, but still the same results. So I don't think it is the actual instrument cluster?? With the odometer not working as well, I'm wondering if it could be something other than that?

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748614
01/28/20 09:09 PM
01/28/20 09:09 PM
Joined: Feb 2007
Posts: 2,843
New York border
Cragar Offline
trapper
Cragar  Offline
trapper

Joined: Feb 2007
Posts: 2,843
New York border
I had an 04 GMC Serria 2500HD , same truck.
There was a recall of some sorts for the speedo , had it replaced for free a few years back. Never had a problem with mine , just got the notice in the mail and got it done.

Link -
https://drspeedometer.com/silverado-speedometer-recall

It looks like the time to have this done has expired. Check with your dealer , ask nicely to see the factory rep , maybe you might get some help.

Last edited by Cragar; 01/28/20 09:14 PM. Reason: Added link

NRA benefactor member
Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748619
01/28/20 09:11 PM
01/28/20 09:11 PM
Joined: Jan 2009
Posts: 2,816
Nebraska
Trapset Offline
trapper
Trapset  Offline
trapper

Joined: Jan 2009
Posts: 2,816
Nebraska
Almost always the cluster.


www.rtssetter.com for dealer list:
RTS SETTER*RTS COLLAPSE A CUBBY *RTS SPEED GAMBREL*SCANDINAVIAN FUR TRAPPER MANUAL*TRAPPERS THANK YOU & XMAS CARDS
Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748634
01/28/20 09:27 PM
01/28/20 09:27 PM
Joined: Jun 2018
Posts: 3,237
Beatrice, NE
L
loosegoose Offline
trapper
loosegoose  Offline
trapper
L

Joined: Jun 2018
Posts: 3,237
Beatrice, NE
Originally Posted by Nothwoods Bandit
I don't think it's in the cluster, I had some issues with the speedo a couple years ago and replaced the stepper motor and it worked fine. At that time the needle had been jumping all over the place and sometimes got stuck, but this time it just stays at the zero mark and doesn't move at all?? All the other gauges work fine, and I did replace the stepper again on the speedo, but still the same results. So I don't think it is the actual instrument cluster?? With the odometer not working as well, I'm wondering if it could be something other than that?



Neither the vehicle speed sensor not the crank sensor (which detects engine RPM) communicate directly with the instrument cluster. They both communicate with the power train control module, which they communicates the info to the instrument cluster over a network. If there was a problem with the crank sensor you would have a check engine light,and most likely an engine that wouldn't start. If you had a problem with the vehicle speed sensor you'd likely also have a problem with the ABS as well, as vehicle speed is an important input for antilock brakes. It's be extremely rare to have a problem at the same time with both sensors but I suppose it's possible. A scan tool would easily reveal that info. But it'd be even more rare to have a problem with both systems in a way that didn't also cause a check engine light or ABS issues. I suppose it's possible but highly unlikely. All the other gauges (oil pressure and voltage and fuel level) also get their info from the same network as the speedo and tach, so we can eliminate a network problem, and we know it has power and ground since the other gauges work, so that leaves the instrument cluster itself as the likely culprit.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: loosegoose] #6748642
01/28/20 09:35 PM
01/28/20 09:35 PM
Joined: Sep 2010
Posts: 116
upper michigan
N
Nothwoods Bandit Offline OP
trapper
Nothwoods Bandit  Offline OP
trapper
N

Joined: Sep 2010
Posts: 116
upper michigan
Originally Posted by loosegoose
Originally Posted by Nothwoods Bandit
I don't think it's in the cluster, I had some issues with the speedo a couple years ago and replaced the stepper motor and it worked fine. At that time the needle had been jumping all over the place and sometimes got stuck, but this time it just stays at the zero mark and doesn't move at all?? All the other gauges work fine, and I did replace the stepper again on the speedo, but still the same results. So I don't think it is the actual instrument cluster?? With the odometer not working as well, I'm wondering if it could be something other than that?



Neither the vehicle speed sensor not the crank sensor (which detects engine RPM) communicate directly with the instrument cluster. They both communicate with the power train control module, which they communicates the info to the instrument cluster over a network. If there was a problem with the crank sensor you would have a check engine light,and most likely an engine that wouldn't start. If you had a problem with the vehicle speed sensor you'd likely also have a problem with the ABS as well, as vehicle speed is an important input for antilock brakes. It's be extremely rare to have a problem at the same time with both sensors but I suppose it's possible. A scan tool would easily reveal that info. But it'd be even more rare to have a problem with both systems in a way that didn't also cause a check engine light or ABS issues. I suppose it's possible but highly unlikely. All the other gauges (oil pressure and voltage and fuel level) also get their info from the same network as the speedo and tach, so we can eliminate a network problem, and we know it has power and ground since the other gauges work, so that leaves the instrument cluster itself as the likely culprit.



Would this also cause the odometer not to register?? I guess that was why I thought perhaps it could be one of the speed sensors either connected by they wheels or the ones on the transmission. I currently don't have any dash lights on, and I did plug in my code reader and it said NO Codes found.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6748867
01/29/20 07:27 AM
01/29/20 07:27 AM
Joined: Oct 2009
Posts: 2,643
east central WI
K
k snow Offline
trapper
k snow  Offline
trapper
K

Joined: Oct 2009
Posts: 2,643
east central WI
Those clusters were junk. I replaced dozens of them in trucks over the years.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6749861
01/29/20 08:16 PM
01/29/20 08:16 PM
Joined: Feb 2007
Posts: 406
N. Dakota
1
1lessdog Offline
trapper
1lessdog  Offline
trapper
1

Joined: Feb 2007
Posts: 406
N. Dakota
There is a place I had mine fixed. Had it back in 4 days. And drove my truck with out it in.

They had mine for less than 24 hrs.


https://circuitboardmedics.com/chevrolet-instrument-cluster-repair/


Last edited by 1lessdog; 01/29/20 08:17 PM.
Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6749873
01/29/20 08:21 PM
01/29/20 08:21 PM
Joined: Nov 2017
Posts: 270
SD
T
Turd Furgeson Offline
trapper
Turd Furgeson  Offline
trapper
T

Joined: Nov 2017
Posts: 270
SD
My 05 did same thing, it was the cluster.

Re: 2003 Chevy Silverado, Mechanic ?? [Re: Nothwoods Bandit] #6750022
01/29/20 09:24 PM
01/29/20 09:24 PM
Joined: Jan 2014
Posts: 5,228
Virginia
5
52Carl Offline
trapper
52Carl  Offline
trapper
5

Joined: Jan 2014
Posts: 5,228
Virginia
Sounds to me like the consensus is "cluster **** ."

Re: 2003 Chevy Silverado, Mechanic ?? [Re: 52Carl] #6750032
01/29/20 09:30 PM
01/29/20 09:30 PM
Joined: Feb 2007
Posts: 2,843
New York border
Cragar Offline
trapper
Cragar  Offline
trapper

Joined: Feb 2007
Posts: 2,843
New York border
Originally Posted by 52Carl
Sounds to me like the consensus is "cluster **** ."

Voted best comment of the thread........lol


NRA benefactor member
Previous Thread
Index
Next Thread